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Abstract

In this practical, we will calculate the structure of the Tudor domain (Selenko P, Sprangers
R, Stier G, Buhler D, Fischer U, Sattler M., 2001, Nat Struct Biol 8:27-31) with ARIA2. The
data comprise two NOESY specta, torsion angles from coupling constants, hydrogen bond
restraints, and residual dipolar couplings.
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1 Start ARIA

ARIA is written in the python language and need a valid python version with some particular
packages as Numpy. For this practical, this installation is already done, but you can get
more details about it on the ARIA web site http://www.aria.pasteur.fr.

First, setup the environment for ARIA:

1. Open a terminal window

2. Type the following command in the terminal

source setup -aria.sh

3. Unpack the archive containing the data for the tutorial by typing

tar -xzf nilges.tgz

4. And go to the example/ directory

cd example/

This gives you an overview of the options.

2 Create your ARIA project

To create an ARIA project, you need:

• The sequence of your protein

• Chemical shifts assignments

• NOESY peaks-lists

• Additional NMR data if available

ARIA can import NMR data from various NMR formats (requires a conversion step) or
directly from a CCPN project. The latter option is the one described in this tutorial.

ARIA provides a Graphical User Interface (GUI) to fill in the specified information (Input
data and location of the output).

The GUI indicates where information are missing by a red exclamation mark . You also
need to set parameters for ARIA and, if you want, to modify parameters for CNS (Figure 1).

1. Start the ARIA user interface (GUI) with the command

aria2 -g

2. Select Project→New in the menu to create a new project

3. Fill in the missing information in the Project panel

4. Enter tudor in the File Root field

5. Set Working directory and Temporary path to the example/ directory in your
home directory.
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Figure 1: ARIA Graphical User Interface (GUI).

6. Select the CCPN project file. To do this, you need to fill the Project field in the CCPN
data model node. Use the Browse button and select the ccpn/tudor directory that
contains the CCPN project. Note: Do not worry for the warning pop-up window and
just hit Ok.

Since data are from a taken from CCPN project, you can also export ARIA results
(calculated structures, restraints lists and NOE assignments) back to CCPN.

7. In the Options frame, set

Export restraints list : Last iteration

Export assignments : Yes

Export structures : Yes

8. Select the molecular system (Figure 3). In the node Data → Molecular System,
choose the format CCPN and use the Select... button to open a CCPN windows, in
which you can choose the Tudor Molecular System from the CCPN project.

Adding NOESY data

1. Add a NOESY spectrum panel by selecting Spectrum in the “Add...” menu.

2. In the new node Data→ Spectra→ #x, select the CCPN format for both the Chemical
Shift List and the Spectrum.

3. With the Select... button, choose the 13C Shift List for the Chemical Shift List

4. Again with the Select... button, choose 13C NOESY as Spectrum
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Figure 2: Use a CCPN project in an ARIA project.

5. Repeat point 1 to 4 for the 15N 3D NOESY.

6. Specify the chemical shift tolerances for the different NOE spectra (freq. window)

7. Leave the the default value (0.5 ppm) for the heteronuclear dimensions.

8. For the proton dimensions, use 0.04 ppm for the indirect dimension (proton1) and
0.02 ppm for the direct dimension (proton2).

9. For each spectra, turn off the use of the manual assignments by setting Use manual
assignment to No. Otherwise, leave Use manual assignment to Yes if you want
ARIA to use the NOE assignment already present in the peak list. You may also want
to remove the diagonal peaks by enabling the Filter diagonal peaks option.

Adding other NMR data

The CCPN project contains also hydrogen bonds and dihedral angle restraints.

1. For each of them, add the corresponding restraints list with the “Add...” menu.

2. Select CCPN format and use the Select... button to locate them in the CCPN project
(Note: as there is only one constraint list of each, the default one is automatically
selected).

3. In our example, RDC restraints were not stored in the CCPN project. You can still
add them in the ARIA project with the “Add...” menu and using the original data file
./data/rdcs/rdc2.tbl (Figure 1).

4. Specify the alignment tensor for the RDC data. Go to Structure Generation →
CNS→ Annealing Parameters→ RDCs→ class 1. Rhombicity is 0.22 and mag-
nitude 7.5.
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5. Go to node Structure Generation → CNS and fill in with the path to the CNS
program which is used to perform the actual structure calculation.

/Bis/home/bardiaux/bin/cns1.21.exe

6. Save this project into the file aria project.xml in the example/ directory (Menu
Project→Save as...)

7. Quit the GUI (Menu Project→Exit)

Analysis parameters

• Structures quality can be analyzed with Whatif, Procheck, Prosa and Molprobity.
One could enter the corresponding paths in the node Analyses. To save time, these
analysis have been already performed for this example.

• To see a 2-dimensional “Peak Map” in the GUI after the structures calculation, you
need to enable the python pickle output in the node Report.

Do not forget to save the project as aria project.xml in the example/ directory.

3 Running ARIA

1. Setup the ARIA project directory by typing

aria2 --setup aria_project.xml

This command will create the working directory (run1/) and copy all files needed to
perform structures calculation.

2. To speed up the calculation for the practical, copy the pre-calculated structures to
your directory tree:

cp -r ../results/structures ./run1/

3. Then start ARIA with

aria2 aria_project.xml

First, the data are filtered for errors and inconsistencies. ARIA then proceeds with cre-
ation of the molecular topology. Afterwards a initial assignment of NOE cross-peaks is
derived from the chemical shift lists. Finally, ARIA determines which files are missing and
calculates them.

Time for a break ?

4 Analysing ARIA output

4.1 PDB files

For each iteration, you will find the PDB files of the generated structures in their respective
directories run1/structures/itxxx.
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. Visualise the ensemble of solvent-refined structures with the program
Pymol:
pymol run1/structures/refine/fitted tudor water.pdb

To show secondary structures, type the command dss in Pymol
and then choose S → as → cartoon in the right menu. You
can visualise all superimposed structures with Movie → Show all
states.

4.2 Text output

ARIA generates various output files to report analysis results. For every iteration, the pro-
gram creates the following report files:

1. noe restraints.unambig and noe restraints.ambig
These files tabulate unambiguous and ambiguous restraints, respectively. Restraints
discarded by the merging procedure are excluded. For every restraint, information is
given on its reference cross-peak, restraint bounds, the average distance found in the
ensemble and the result of violation analysis.

2. noe restraints.violations
Lists all violated restraints sorted with respect to their upper bound violations and
contains the same information as (1).

3. noe restraints.assignments
Lists primarily restraint-wise assignments and gives information whether the assign-
ment(s) stem from fully, partially or unassigned cross-peaks.

4. noe restraints.merged
Reports all restraints that have been discarded by the merging procedure.

5. report
Summarises analyses of the restraint lists and the structure ensemble.

. Look at the report for the last iteration run1/structures/it8/report.

• How many peaks remain ambiguous ?

• What is the precision of the final structure ensemble ?

Quality checks. ARIA uses the programs WHAT IF, PROCHECK, PROSA II and MOL-
PROBITY to evaluate the quality of both the final set of structures and the solvent-refined
ensemble. For every program separate report files, quality checks.*, are stored in the
directories of the respective ensembles.

. Compare the overall quality scores (quality checks) for the last
iteration (run1/structures/it8/) and for the water refinement
(run1/structures/refine/).
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Miscellaneous analyses. Several CNS scripts calculate restraint energies, ensemble
RMSDs, and an average structure. Results are stored in /analysis/.

. Take a look at the restraint violations statistics for distance re-
straints (noes.disp), dihedrals angles (dihedrals.disp) and RDCs
(sani.disp) in the refine/analysis/ directory.

4.3 Graphics output

In the it8/graphics directory, you can find two PostScript files (use evince to open them).

• The first one, shows the RMS violation by residue in 1- and 2-dimensional plots:
run1/structures/it8/graphics/rms analysis.ps

• The second one shows different WHAT-IF Z-scores along the protein sequence:
run1/structures/it8/graphics/whatif profiles.ps

. Regions of the structures with lower quality can be easily detected from
this plots

4.4 GUI output

This option is available only if you enable the python pickle output of the Report node.
Open your aria project.xml project file with the ARIA Gui
(aria2 -g aria project.xml) and open the node Peak Maps→ it8.

. You can see a contact map based on the NOE assignments and get
details on inter-residue constraints by clicking on the crosses of the map.

4.5 CCPN output

ARIA can export results back to the CCPN project. You can visualise the content of the
CCPN project with the program CcpNmr Analysis.

1. Start CcpNmr Analysis by typing

analysis

2. With Project → Open Project, select the ccpn/tudor project.

3. New NOE peak-lists containing assignments made by ARIA are visible in the Peak
→ Peak Lists window (Figure 3)

4. Distance restraints created by ARIA are listed in the Structure → Restraints
and Violations window (Restraint Set 2)

5. Structures of the last iteration and of the water refinement are also present in the
Structure → Structures window.
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Figure 3: ARIA output in CCPNmr Analysis

5 Advanced exercises

1. Go to the advanced/ directory.

cd advanced/

5.1 Spot the difference

The directory run2/ contains the result of an ARIA calculation for the tudor domain, with
the same data as in the tutorial. Here, a parameter has been changed in the definition of
the ARIA protocol.

. • Compare this result with the one obtained in run1 (violations/pre-
cision/structure quality)

• What parameter could explain the differences ?

5.2 Obvious mistake

The directory run3/ contains the result of another ARIA calculation for the tudor domain.
Yet, the result obtained in this case may not be very satisfactory :

. • Why is this result not satisfactory ?

• If you think something went wrong, could you point it out ?

• What would be the possible origin(s) for this (deliberate) error ?
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5.3 Symmetric dimer

The directory dimer/run1 contains the result of an ARIA calculation for a symmetric dimer.

. • Analyze the violations and quality parameters of dimer/run1

• Visualize the ensemble of structures. Does this result look reason-
able ?

Now, move to the the directory dimer/run2 which contains another result from ARIA
for the same symmetric dimer with the same input data.

. • Compare the ensembles of structures of dimer/run1 and
dimer/run2

• What would be the more plausible solution ? Why ?

• Can you identify the incriminated restraint(s) ?

Note: You can check the violations in the file noe restraints.assignments (lines with
viol: yes)

Links

ARIA http://aria.pasteur.fr

CCPN http://www.ccpn.ac.uk

CNS http://cns-online.org

WHAT IF http://swift.cmbi.ru.nl/whatif/

PROCHECK http://www.ebi.ac.uk/thornton-srv/software/PROCHECK/

MolProbity http://molprobity.biochem.duke.edu/
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6 Answers for advanced exercises

6.1 Spot the difference

Here, we used a log-harmonic potential instead of the classical flat bottom harmonic wall
potential for the distance restraints. In addition, the optimal weight applied on the distance
restraints was determined automatically. The final average weight for the NOE restraints
is 10.6 kcal.mol−1 (where it was 50 kcal.mol−1.Å−2 with the flat potential). The general
quality of the structures is better with fewer clashes. See Nilges et al. Structure, 2008 for
details.

6.2 Obvious mistake

Here, we deliberately exchanged assignments of Cys20 and Cys45. Moreover, we asked
ARIA to use the manual assignment and to keep them until the end of the calculation.
The resulting structures failed to converge due to the incoherent restraints with the two
cysteines. One can detect such errors by looking at the file rms analysis.ps for instance
(large peaks for residues 20 and 45).

6.3 Symmetric dimer

In run1, helix α1 is swapped from one monomer to the other. We actually used the network-
anchoring with stringent thresholds and for the first 3 ARIA iterations. Even if the the struc-
tures appear reasonable according to violations, precision and global structure quality, one
can detect the error when looking at the WHAT IF scores along the sequence and in partic-
ular the backbone and bumps checks (residues 32 to 36). The incorrect fold comes from the
mis-assignment of intra-molecular cross-peaks as inter-molecular. For instance, VAL43HB–
LEU30HA and TYR21HB#–VAL38HG2# (peaks 251 and 1407 of 13C NOESY). The correct
expected structures are in run2. See the following reference for details: Bardiaux et al., In-
fluence of different assignment conditions on the determination of symmetric homodimeric
structures with ARIA. Proteins (2008) vol. 75 (3) pp. 569-585
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