Personal tools
You are here: Home / Documentation / Tutorials / HOW-TO: run ARIA 2.2 with a Zinc ion bound to CYS (and HIS)

HOW-TO: run ARIA 2.2 with a Zinc ion bound to CYS (and HIS)

Filed under: , , ,
Here, we provide an example of ARIA run on a structure containing a zinc ion covalently bound to three CYS and one HIS.

OVERVIEW


Here, we provide an example of ARIA run on a structure containing a zinc ion covalently bound to three CYS and one HIS. The archive AriaZinc.tgz contains:
  • some files to be installed in the ARIA distribution to enable the handling of ions Zinc,
  • an example of an ARIA run on the protein Nemo.

In the following, the installation of the files into the ARIA distribution is first explained, and the Nemo example is then described in details, in order to provide guidelines to users willing to run calculations including Zinc.



INSTALLATION


Nota: The slash ("/") character at the end of the environment variable ARIA2, should be removed. The ARIA2 environment variable definition should thus look like:

  ARIA2=/my/aria2/installation/directory

and not:

  ARIA2=/my/aria2/installation/directory/


1) Copy your ARIA2 installation directory


The installation will overwrite some files. If you have already modified your ARIA version or if you want to keep the original ARIA version, you should install the Zinc version in a copy of your ARIA installation folder:

cp -r ${ARIA2} ${ARIA2}_ZINC

This zinc patch was tested with the ARIA2 release of 15/04/08 which is available here, and it should be compatible with next releases of aria2.x.


2) Copy and uncompress the attached AriaZinc.tgz file into the new ARIA2 installation directory (${ARIA2}_ZINC)

The commands are:
cp AriaZinc.tgz ${ARIA2}_ZINC/
cd ${ARIA2}_ZINC/
tar -xvzf AriaZinc.tgz


If you are using the Zinc version of ARIA, you have to redefine the ARIA2 environment variable:

ARIA2=/my/aria2/installation/directory_ZINC

If you want to use the standard ARIA version, the ARIA2 environment variable should be defined as:

ARIA2=/my/aria2/installation/directory       


Installation of AriaZinc is now done... To run it, use the command:

/usr/bin/python2.X   ${ARIA2}/aria2.py


3) CCPN compatibility


To import a CCPN project into the ARIA Zinc version, we need to define CZN and CYO residues into CCPN. These residue definitions are in the file ccpnmr1.0_CYOandCZNdefinition.tgz, that you have to uncompress into you CCPN installation directory:
cp ccpnmr1.0_CYOandCZNdeifintion.tgz ${CCPNMR_TOP_DIR}/
cd ${CCPNMR_TOP_DIR}/
tar -xvzf ccpnmr1.0_CYOandCZNdeifintion.tgz


This step will add two residue definition files into your CCPN distribution:

${CCPNMR_TOP_DIR}/ccpnmr1.0/data/ccp/chemComp/protein/CZN.xml
${CCPNMR_TOP_DIR}/ccpnmr1.0/data/ccp/chemComp/protein/CYO.xml


Your CCPN version is now compatible with the Aria Zinc version.


TUTORIAL


Now, we will show you how use it with a short example. The example is explained, either by using the conversion utility of ARIA, either by importing a CCPN project.
The example is stored in the directory:

${ARIA2}/examples/nemo/


These data were kindly provided by Florence Cordier (Unite de RMN des Biomolecules, Institut Pasteur). The work was initiated by  Iñaki Guijarro (Unite de RMN des Biomolecules, Institut Pasteur).


I/ Description using the ARIA conversion utility:


1) Edit the sequence file:

In this example a zinc ion is bound to 3 CYS and 1 HISD.
Consequently, we will use two new residues: CZN (CYS -H +ZN) and CYO (CYS -H), and a standard Histidine patch (HISD) already implemented in ARIA.

One has first to define in the .seq file, the residues attached to the Zinc ion. The original sequence file (${ARIA2}_ZINC/examples/nemo/data/nemo.seq) has to be converted by hand into a new sequence file containing one CZN and two CYO residues. (the resulting sequence file should look like ${ARIA2}_ZINC/examples/nemo/data/nemo_patched.seq). In this example, the Zinc ion (present in residue CZN 6) is also bound to the residues CYO 9, CYO 26, and HISD 22.

Note: The HIS 22 have the same name in both .seq files. Indeed, we will patch it later with a standard HISD patch.


2) Convert your data using the file conversion.xml


The file conversion.xml is generated and filled as usual in ARIA, and the ARIA project xml file is then generated using:

/usr/bin/python2.X  ${ARIA2}/aria2.py  --convert conversion.xml



3) Complete the ARIA project xml file


The ARIA project is prepared as usual. In the given example, you have to add the two following restraint files:

./data/dihedrals.tbl
./data/hbonds.tbl


For the residue His-22, in panel Project->Data->HIS patches, add an HISD patch. The residue number is 22 and the segid is "    ".

In the archive ARIA_ZN.tgz, the correct result project is stored in AriaProject_ready.xml.


4) Setup the project

Done as usual in ARIA:

/usr/bin/python2.X  ${ARIA2}/aria2.py  -s AriaProject.xml


This command will create the folder run1/ with all necessary files.


5) Edit the file run1/cns/protocols/run.cns


In this file, we need to activate some patches dependent on your sequence and on Zinc conformation.


5.1) Go to the Zinc patch lines

First search the lines:

{=========================== Zinc patches ==============================}
{* Aymeric BERNARD *}
{* Put here your zinc patch declaration *}
{* See the file ${ARIA2}/examples/nemo/run_patched.cns as example *}

to add here the zinc patch statements.


5.2) add patches for the bound Zinc

In this example we have a tetrahedral conformation as:

Zinc Conformation 2

The ZN ion is already included in the CZN_6 residue. So we just need to define the bonds between CZN_6 and CYO_9, CZN_6 and CYO_26, CZN_6 and HISD_22. We use two CZN-CYO patches, defined in the following way:

evaluate (&toppar.czco_bridge=2)         ! total number of CZN-CYO patches.

evaluate (&toppar.czco_i_resid_1=6)
evaluate (&toppar.czco_i_segid_1=" ") ! CZN_6
evaluate (&toppar.czco_j_resid_1=9)
evaluate (&toppar.czco_j_segid_1=" ") ! CYO_9

evaluate (&toppar.czco_i_resid_2=6)
evaluate (&toppar.czco_i_segid_2=" ") ! CZN_6
evaluate (&toppar.czco_j_resid_2=26)
evaluate (&toppar.czco_j_segid_2=" ") ! CYO_26


We also use one CZN-HISD patch

evaluate (&toppar.czhd_bridge=1)         ! total number of CZN-HISD patches.

evaluate (&toppar.czhd_i_resid_1=6)
evaluate (&toppar.czhd_i_segid_1=" ") ! CZN_6
evaluate (&toppar.czhd_j_resid_1=22)
evaluate (&toppar.czhd_j_segid_1=" ") ! HISD_22



5.3) add Zinc angle patches

We need to define angles between CYO-ZN-CYO and CYO-ZN-HISD through one CYO-CYO patch:

evaluate (&toppar.coco_bridge=1)         ! total number of CYO-CYO patches.

evaluate (&toppar.coco_i_resid_1=9)
evaluate (&toppar.coco_i_segid_1=" ") ! CYO_9
evaluate (&toppar.coco_j_resid_1=6)
evaluate (&toppar.coco_j_segid_1=" ") ! CZN_6
evaluate (&toppar.coco_k_resid_1=26)
evaluate (&toppar.coco_k_segid_1=" ") ! CYO_26


We also use two CYO-HISD patches:

evaluate (&toppar.cohd_bridge=2)         ! total number of CYO-HISD patches.

evaluate (&toppar.cohd_i_resid_1=9)
evaluate (&toppar.cohd_i_segid_1=" ") ! CYO_9
evaluate (&toppar.cohd_j_resid_1=6)
evaluate (&toppar.cohd_j_segid_1=" ") ! CZN_6
evaluate (&toppar.cohd_k_resid_1=22)
evaluate (&toppar.cohd_k_segid_1=" ") ! HISD_22

evaluate (&toppar.cohd_i_resid_2=26)
evaluate (&toppar.cohd_i_segid_2=" ") ! CYO_26
evaluate (&toppar.cohd_j_resid_2=6)
evaluate (&toppar.cohd_j_segid_2=" ") ! CZN_6
evaluate (&toppar.cohd_k_resid_2=22)
evaluate (&toppar.cohd_k_segid_2=" ") ! HISD_22


The file ${ARIA2}_ZINC/examples/nemo/run_patched.cns is the resulting run.cns file. If you want to use this file for an ARIA run, you have to copy it to run.cns:

cp run_patched.cns run1/cns/protocols/run.cns



6) Launch the project:


The project is launched as usual in ARIA:

/usr/bin/python2.X  ${ARIA2}/aria2.py  AriaProject.xml


Note: The definition of the Zinc geometry can cause crashes in structure calculation. In this case, change the seed (panel Project->Structure Generation->CNS->Dynamics: Random seed) and restart the project.



II/ Example using a CCPN project


1) Edit the sequence file

Same protocol than for the ARIA conversion (see section I.1)


2) Create your CCPN project

Here, we will use the FormatConverter tool to create a CCPN project file:

${CCPNMR_TOP_DIR}/bin/formatConverter -noThread &


2.1) create CCPN project

Go into the menu Project -> New.


2.2) Import the sequence

Import -> Single Files -> Sequence -> NmrView
Choose ./data/nemo_patched.seq file and follow instructions...
Nota: For nemo, there is only one chain ('A') and the first residue number is '1'


2.3) Import the Spectrum

Import -> Combined Files -> Chemical Shifts and Peaks -> NmrView
Select files: ./data/noesy25c.ppm and ./data/noesy25c.xpk
Nota: For nemo, experiment type is "H_H.NOESY" and use Automated LinkResonnance
protocol to link chemical shifts to atoms.


2.4) Import dihedrals and hbonds

Import -> Single Files -> Dihedral Constraints -> Cns
and choose the file ./data/dihedrals.tbl

Import -> Single Files -> H-bonds constraints -> Cns
and choose the file ./data/hbonds.tbl


2.5) Save your Project

Go into the menu Project -> Save. The resulting project should look like nemo.xml


3) Import CCPN data into the an ARIA project file


3.1) Create a new ARIA project

/usr/bin/python2.X  ${ARIA2}/aria2.py -g

and go into the menu Project -> New.

3.2) Import the CCPN project

Go into the menu Project -> CCPN data model, and select the file of your CCPN project (eg. nemo.xml)

3.3) Select the sequence

Go into the menu Project -> Data -> Molecular System. Select the format "CCPN" and use the "Select..." button to
select the nemo MolSystem from the CCPN project.

3.4) Add the spectrum

Go into the menu Add... -> Spectrum  and Project -> Data -> Spectra -> #1
For the chemical shift list and the peak list, select the format
CCPN and use the "Select..." button to find the spectrum from the CCPN
project.


3.5) Add dihedrals and hbonds

Go into the menu Add... -> Dihedral angle restraints and Project -> Data -> Dihedral angles -> #1
choose the CCPN format and use the "Select..." button to find the dihedral
restraints list from the CCPN project.

Go into the menu Add... -> Hydrogen bonds restraints and Project -> Data -> Hydrogen bonds -> #1
choose the CCPN format and use the "Select..." button to find the Hydrogen
bonds restraints list from the CCPN project.

3.6) Add an Histidine Patch

Go into the menu Project -> Data -> Histidine patches, and add an histidin patche for the residue 22 of the segid ' A'


3.7) complete missing values in the ARIA project

  • the file root (Project)
  • the CNS local executable (Project -> Structure Generation -> CNS)
  • Host list, ...



4) Setup the project

Same protocol than for the ARIA conversion (see section I.4)


5) Edit the file run1/cns/protocols/run.cns

Same protocol than for the ARIA conversion (see section I.5)


6) Launch the project

Same protocol than for the ARIA conversion (see section I.6)






« June 2017 »
June
MonTueWedThuFriSatSun
1234
567891011
12131415161718
19202122232425
2627282930